dpkg: warning: ‘ldconfig’ not found in PATH or not executable

Intentando instalar paquetes que no son soportados por la distribucion instale paquetes de otra version (sid) entonces al ejecutar el comando apt-get install me sale el siguiente error:

apt-get install -f

Error:

The following NEW packages will be installed:
  libc-bin libsctp1 lksctp-tools mtp-tools task-gnome-desktop 
The following packages will be REMOVED:
  bluez-cups{a} cups{a} hp-ppd{u} hplip{a} lib32asound2{u} lib32z1{u} libc6-i386{u} libgadu3{u} libgssglue1{u} libmozjs24d{u} libossp-uuid16{u} openjdk-7-jre-lib{u} postgresql-common{u} 
  postgresql-doc{u} printer-driver-gutenprint{a} printer-driver-hpcups{a} printer-driver-postscript-hp{a} printer-driver-splix{a} task-print-server{a} xulrunner-24.0{u} 
The following packages are RECOMMENDED but will NOT be installed:
  gnome hyphen-en-us libreoffice-evolution libreoffice-gnome libreoffice-help-en-us mythes-en-us 
0 packages upgraded, 5 newly installed, 20 to remove and 109 not upgraded.
Need to get 0 B/1453 kB of archives. After unpacking 69.1 MB will be freed.
Do you want to continue? [Y/n/?] y
Can't set locale; make sure $LC_* and $LANG are correct!
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "en_US.UTF-8",
	LC_ALL = "en_US.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Can't exec "locale": No such file or directory at /usr/share/perl5/Debconf/Encoding.pm line 16.
Use of uninitialized value $Debconf::Encoding::charmap in scalar chomp at /usr/share/perl5/Debconf/Encoding.pm line 17.
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: error: 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)
A package failed to install.  Trying to recover:
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: error: 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin

solucion:

Bajar el paquete deb

apt-get download libc-bin

descomprimir el mismo

dpkg -x libc-bin*.deb unpackdir/

mover a la ruta correcta

cp unpackdir/sbin/ldconfig /sbin/

reinstalar el paquete

apt-get install --reinstall libc-bin

Fuente: ubuntuforums.org

Publicado en debian, GNU/Linux, Instalacion, Terminal

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

Categorías

enero 2016
L M X J V S D
« Dic   Feb »
 123
45678910
11121314151617
18192021222324
25262728293031