Archivo del sitio

pip install psycopg2 error x86_64-linux-gnu-gcc

Intento instalar el modulo para conectarme a postgres y me da este error In file included from psycopg/psycopgmodule.c:27:0:   ./psycopg/psycopg.h:30:20: fatal error: Python.h: No such file or directory   compilation terminated.   error: command ‘x86_64-linux-gnu-gcc’ failed with exit status 1In

Publicado en debian, GNU/Linux, Instalacion, postgresql, Python

debian + Postgresql error en extension unnaccent

Cuando intento crear una extensión para una base de datos: postgres=# \connect sem; sem=# CREATE EXTENSION unaccent;postgres=# \connect sem; sem=# CREATE EXTENSION unaccent; ERROR: could not open extension control file "/usr/share/postgresql/9.4/extension/unaccent.control": No such file or directoryERROR: could not open extension

Publicado en debian, GNU/Linux, Instalacion, postgresql, Programación, Terminal

PostgresSQL Cantidad de registros de todas las tablas

Ejecutar la siguiente sentencia: SELECT schemaname,relname,n_live_tup FROM pg_stat_user_tables ORDER BY n_live_tup DESC;SELECT schemaname,relname,n_live_tup FROM pg_stat_user_tables ORDER BY n_live_tup DESC;

Publicado en postgresql, Programación

postgresql cambiar constraseña de usuario

El procedimiento para cambiar la contraseña de un determinado usuario en postgres es: root@:/# su postgres postgres@:/$ psql postgres=# alter user nombreDeUsuario with password ‘NewPassword’;root@:/# su postgres postgres@:/$ psql postgres=# alter user nombreDeUsuario with password ‘NewPassword’;

Publicado en GNU/Linux, postgresql, Programación, Terminal

debian: install pgadmin4

Creamos un entorno virtual y activamos el mismo, como por ejemplo así Descargar el paquete necesario de pgadmin4 wget -c https://ftp.postgresql.org/pub/pgadmin3/pgadmin4/v1.3/pip/pgadmin4-1.3-py2.py3-none-any.whlwget -c https://ftp.postgresql.org/pub/pgadmin3/pgadmin4/v1.3/pip/pgadmin4-1.3-py2.py3-none-any.whl Luego hacemos uso de pip para instalarlo pip install pgadmin4-1.3-py2.py3-none-any.whlpip install pgadmin4-1.3-py2.py3-none-any.whl Ahora hay que buscar el

Publicado en debian, GNU/Linux, Instalacion, postgresql, Programación, Terminal

Django No module named ‘psycopg2’

  Instalar dependencias: apt-get build-dep python-psycopg2apt-get build-dep python-psycopg2   dentro del virtualenv instalo el soporte para postgresql pip install psycopg2pip install psycopg2

Publicado en debian, Django, GNU/Linux, postgresql, Programación, Python, Terminal, Ubuntu Etiquetado con:

Categorías

noviembre 2018
L M X J V S D
« Oct    
 1234
567891011
12131415161718
19202122232425
2627282930